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1. Welcome

About SoloStaff Invoice

SoloStaff Invoice is a professional desktop invoicing application designed for freelancers, consultants, and
small businesses. It provides everything you need to create professional invoices, track payments, manage
customers, and grow your business.

Key Features

Professional Invoicing - Create, edit, and send polished invoices
Customer Management - Maintain a complete database of clients and their billing information
Product Catalog - Store your products and services for quick invoice creation
Recurring Invoices - Automate regular billing with scheduled invoice generation
PDF Generation - Generate professional PDF invoices with multiple template options
Email Integration - Send invoices directly to customers via SMTP
Comprehensive Reports - Track revenue, analyze trends, and monitor outstanding payments
Dark Mode - Work comfortably with light or dark themes (toggle with Ctrl+Shift+T)
Accessibility - Full keyboard navigation and screen reader support
Local-First - Your data stays on your computer with no cloud dependencies
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System Requirements

Component Minimum Recommended

RAM 4 GB 8 GB

Disk Space 200 MB 500 MB

Display 1280 x 720 1920 x 1080

Supported Platforms

Platform Minimum Version

Windows Windows 10 (64-bit)

macOS macOS 10.14 Mojave

Linux Ubuntu 20.04 LTS or equivalent

2. Installation
SoloStaff Invoice is distributed as a standalone application that includes everything needed to run. No
additional software installation is required.

2.1 Windows

1. Extract the distribution

Extract SoloStaff_Invoice_v0.4.1-alpha_Windows.zip to your preferred location
Recommended: C:\Program Files\SoloStaff Invoice\ or your user folder

2. Run the application

Double-click SoloStaff_Invoice.exe to launch

3. Optional: Create a shortcut

Right-click SoloStaff_Invoice.exe
Select "Create shortcut"
Move the shortcut to your Desktop or Start Menu

Windows Notes:

First Launch: Windows SmartScreen may show a warning for unrecognized applications. Click "More
info" then "Run anyway" to proceed.

Windows Defender: For optimal startup performance, consider adding the application folder to
Windows Defender exclusions:

1. Open Windows Security
2. Go to Virus & threat protection > Manage settings
3. Scroll to Exclusions > Add or remove exclusions
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4. Add the application folder

Data Locations (Windows):

Data Location

Database %USERPROFILE%\.invoice_app\invoice_app.db

Settings %APPDATA%\InvoiceApplication\config.json

Backups %USERPROFILE%\.invoice_app\backups\

2.2 macOS

1. Extract the distribution

Extract SoloStaff_Invoice_v0.4.1-alpha_macOS.zip
Drag SoloStaff Invoice.app to your Applications folder

2. Run the application

Open Applications and double-click SoloStaff Invoice
Or use Spotlight: Press Cmd+Space, type "SoloStaff", press Enter

macOS Notes:

Gatekeeper Warning: On first launch, macOS may show "SoloStaff Invoice cannot be opened because
it is from an unidentified developer."

To open:

1. Go to System Preferences > Security & Privacy > General
2. Click "Open Anyway" next to the message about the blocked app
3. Or: Right-click the app, select "Open", then click "Open" in the dialog

Apple Silicon (M1/M2/M3): The application runs natively on Apple Silicon Macs

Data Locations (macOS):

Data Location

Database ~/.invoice_app/invoice_app.db

Settings ~/Library/Application Support/InvoiceApplication/config.json

Backups ~/.invoice_app/backups/

2.3 Linux

1. Extract the distribution

tar -xzf SoloStaff_Invoice_v0.4.1-alpha_Linux_x64.tar.gz 
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2. Make executable (if needed)

chmod +x SoloStaff_Invoice 

3. Install Qt dependencies (if not already present)

Ubuntu/Debian:

sudo apt install libxcb-cursor0 libxcb-xinerama0 

Fedora/RHEL:

sudo dnf install xcb-util-cursor 

Arch Linux:

sudo pacman -S xcb-util-cursor 

4. Run the application

./SoloStaff_Invoice 

Linux Notes:

Desktop Entry: To add the application to your application menu, create
~/.local/share/applications/solostaff-invoice.desktop:

[Desktop Entry]
Name=SoloStaff Invoice 
Comment=Professional invoicing application 
Exec=/path/to/SoloStaff_Invoice 
Icon=/path/to/icon.png 
Type=Application 
Categories=Office;Finance;

Wayland/X11: The application supports both display servers

WSL2: Running under Windows Subsystem for Linux requires WSLg (Windows 11) or an X server like
VcXsrv



user-manual.md 2025-12-21

5 / 56

Data Locations (Linux):

Data Location

Database ~/.invoice_app/invoice_app.db

Settings ~/.config/invoice-application/config.json

Backups ~/.invoice_app/backups/

2.4 Verifying Installation

After launching the application:

1. The main window should appear with the Dashboard view
2. Navigate to Help > About to verify the version is 0.4.1-alpha
3. Go to Edit > Settings to confirm all options are accessible

3. Getting Started

3.1 First Launch

When you first launch SoloStaff Invoice, you'll be greeted with the Dashboard - your central hub for managing
invoices.

The Dashboard provides quick access to all features and shows your recent activity
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3.2 Quick Start: Your First Invoice

Follow these steps to create your first invoice:

Step 1: Configure Your Business

1. Press Ctrl+, (Windows/Linux) or Cmd+, (macOS) to open Settings
2. Navigate to the Business tab
3. Enter your business details:

Business name
Address
Phone and email
Website

4. Click Save

Step 2: Configure Tax Settings

1. In Settings, navigate to the Tax tab
2. Enter your tax information:

Tax name (e.g., "HST", "VAT", "GST")
Tax rate percentage
Tax registration number (optional)

3. Click Save

Step 3: Add a Customer

1. Go to View > Customers from the menu
2. Click New Customer or press Ctrl+Shift+C
3. Enter the customer's details:

Name (required)
Email address
Phone number
Address

4. Click Save

Step 4: Add Your Products/Services (Optional)

1. Go to View > Products from the menu
2. Click New Product or press Ctrl+Shift+O
3. Enter product details:

Name
Description
Default price
SKU (optional)

4. Click Save

Step 5: Configure Email (Before Sending Invoices)



user-manual.md 2025-12-21

7 / 56

Before you can email invoices, you must configure your email settings:

1. Go to Edit > Settings (Ctrl+,)
2. Click Configure SMTP or navigate to email settings
3. Enter your SMTP server details:

SMTP Server (e.g., smtp.gmail.com)
Port (typically 587 for TLS)
Username and password

4. Click Test Connection to verify
5. Click Save

Gmail Users: You must use an App Password:

1. Enable 2-Step Verification on your Google account
2. Go to App Passwords
3. Generate a password for "Mail"
4. Use this app password (not your regular password)

Step 6: Create an Invoice

1. Go to View > Invoices from the menu
2. Click New Invoice or press Ctrl+N
3. Select your customer from the dropdown
4. Add line items:

Select from your product catalog, or
Enter custom item details

5. Review the totals (subtotal, tax, total)
6. Click Save as Draft or Issue to finalize

Step 7: Send the Invoice

1. Select the invoice in the list
2. Click Email or press Ctrl+M
3. Review the email recipient, subject, and message
4. Click Send

3.3 Understanding the Interface

The application uses a consistent layout across all sections:

Menu Bar: Access all features via File, Edit, View, and Help menus
Left Sidebar: Navigate between main sections (Dashboard, Invoices, Customers, Products, Recurring,
Reports)
Toolbar: Quick access to common actions
Main Content Area: Lists, forms, and details
Status Bar: Current status and notifications

4. The Dashboard

https://myaccount.google.com/signinoptions/two-step-verification
https://myaccount.google.com/apppasswords
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The Dashboard is your command center, providing an overview of your invoicing activity and quick access to
common tasks.

Dashboard showing summary statistics, recent invoices, and quick actions

Dashboard Components

Section Description

Summary Cards Key metrics: outstanding balance, overdue invoices, monthly revenue

Recent Invoices Your most recently created or modified invoices

Quick Actions Buttons for common tasks like creating a new invoice

Activity Feed Recent changes and notifications

Quick Actions

New Invoice: Create a new invoice (Ctrl+N)
New Customer: Add a new customer (Ctrl+Shift+C)
New Product: Add a new product (Ctrl+Shift+O)
View Reports: Jump to analytics

5. Settings & Configuration
Access Settings via Edit > Settings or press Ctrl+, (Cmd+, on macOS).
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5.1 Business Settings

Configure your business information that appears on invoices.

Enter your business name, address, and contact information

Field Description

Business Name Your company or trading name
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Field Description

Business Email Primary business email address

Business Phone Business phone number

Business Website Your company website

Business Address Full street address (multi-line)

Company Logo

Add your company logo to appear on generated PDF invoices. The logo section is located at the bottom of
the Business tab.

Logo Requirements:

Requirement Value

Supported Formats PNG, JPG, JPEG, GIF, BMP

Maximum File Size 2 MB

Maximum Dimensions 800 × 300 pixels

Recommended Size 400 × 150 pixels for best quality

To Upload a Logo:

1. Click Upload Logo... button
2. Select an image file from your computer
3. The logo preview will display your selected image
4. Click Save to apply the logo to your invoices

To Remove a Logo:

1. Click Clear Logo button
2. Click Save to confirm

Tips:

Use a PNG file with a transparent background for best results
Keep the logo simple and readable at small sizes
The logo will automatically scale to fit invoice templates while maintaining aspect ratio
If your logo doesn't appear on PDFs, verify the file exists and meets the size requirements

5.2 Invoice Settings

Customize how invoices are numbered and configured.
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Configure invoice numbering, due dates, and default values

Invoice Numbering:

Setting Description

Prefix Text before the number (e.g., "INV-")

Starting Number Next invoice number to use

Padding Number of digits (e.g., 4 = 0001)

Separator Character between prefix and number

Include Year Add year to invoice number

Include Month Add month to invoice number

Reset Yearly Reset numbering each January

Invoice Defaults:

Setting Description
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Setting Description

Payment Due (days) Default days until payment is due

Default Terms Terms text (supports {days} placeholder)

Default Notes Notes that automatically appear on all new invoices (see below)

Default Notes vs Invoice Notes:

Default Notes (Settings > Invoice): Text entered here is automatically copied to the Notes field when
creating a new invoice. This is useful for standard information you want on every invoice, such as
payment instructions, bank details, or company policies.

Notes (on individual invoice): When editing an invoice, you can modify the Notes field for that specific
invoice. Changes only affect that invoice and do not update the Default Notes setting or other invoices.

Planned Feature: Multi-currency support is planned for a future release. This will include a home
currency selection setting in Invoice Settings, allowing you to create invoices in different currencies
with automatic conversion.

5.3 Tax Settings

Configure tax rates for your invoices.
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Set up your default tax rate and tax name

Primary Tax:

Setting Description

Tax Name Name displayed on invoices (e.g., "HST", "VAT", "GST")

Tax Rate Percentage applied to invoices (e.g., 13%)

Tax Number Your tax registration number

Secondary Tax (Optional):

Setting Description

Secondary Tax Name Second tax name (e.g., "PST")

Secondary Tax Rate Second tax percentage

5.4 Preferences
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Customize the application behavior and database settings.

Configure general preferences and backup settings

General:

Setting Description

Confirm before deleting items Show confirmation dialog before deleting records

Enable auto-save Automatically save invoice drafts while editing

Auto-save Interval Time between auto-saves in seconds (default: 300)

Max Recent Files Number of recent files to track

Database:

Setting Description

Database File Name of the database file (read-only)

Backup Directory Folder where backups are stored
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Setting Description

Auto-backup on close Automatically create backup when exiting the application

Max Backups Number of backup files to retain (older backups are deleted)

5.5 Accessibility Settings

Note: To toggle between light and dark mode, press Ctrl+Shift+T at any time.

Customize font size and visual accessibility options for improved usability.

Adjust text size and enable accessibility features

Font Size:

Setting Description

Text
Size

Select from preset sizes: Small (12pt), Medium (14pt), Large (16pt - Default), or Extra Large
(20pt)

Preview Live preview showing sample text at the selected size
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Font size changes take effect immediately throughout the application.

Visual Accessibility:

Setting Description

High contrast focus indicators Enhanced visual highlighting for keyboard-focused elements

Reduce motion and animations Minimize interface animations for users sensitive to motion

5.6 Email Settings

Configure SMTP for sending invoices by email.
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Enter your SMTP server details to enable email sending

You must configure email before sending invoices.

Setting Description

Email Provider Select Gmail, Outlook, Yahoo, or Custom

SMTP Server Mail server address (auto-fills for known providers)

Port SMTP port (typically 587 for TLS)
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Setting Description

STARTTLS Enable STARTTLS encryption

SSL/TLS Enable SSL/TLS encryption

Username Your email account username

Password Email password or app password

Sender Name Your name as it appears to recipients

Sender Email Reply-to email address

Important: Click Test Connection to verify your settings work correctly before attempting to send invoices.

Gmail Setup:

1. Enable 2-Step Verification on your Google account
2. Go to App Passwords (Google Account > Security > App passwords)
3. Generate a password for "Mail"
4. Use this app password in the Password field (not your regular Google password)

5.7 Email Templates

Customize email templates for different scenarios.

Edit email templates with variable placeholders

Available templates:

https://myaccount.google.com/signinoptions/two-step-verification
https://myaccount.google.com/apppasswords
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Invoice Email: Default template when emailing an invoice
Payment Reminder: For overdue invoice reminders
Thank You: Confirmation after payment received

Available Variables:

Variable Description

{{customer_name}} Customer's full name

{{customer_company}} Customer's company name

{{invoice_number}} Invoice number

{{invoice_date}} Invoice issue date

{{due_date}} Payment due date

{{amount}} Invoice total amount

{{amount_due}} Remaining balance owed

{{terms}} Payment terms text

{{notes}} Invoice notes

{{business_name}} Your business name

{{business_email}} Your business email address

{{business_phone}} Your business phone number

Creating Custom Templates:

To create a custom email template:

1. Select an existing template from the list that is closest to what you need
2. Click Duplicate to create a copy
3. Rename the new template to describe its purpose
4. Edit the subject line and body text as needed
5. Use the available variables to personalize the content
6. Click Save to store your custom template

You can create multiple templates for different scenarios, such as templates for different customer types or
special promotions.

6. Managing Invoices
The Invoices section is the heart of the application. Access it via View > Invoices from the menu.

6.1 Invoice List View
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Invoice list in light theme showing all invoices with status indicators

Invoice list in dark theme - toggle with Ctrl+Shift+T
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The invoice list shows:

Invoice number
Customer name
Issue date and due date
Total amount
Status (color-coded)

Filtering and Search:

Use the search box to filter by invoice number or customer name
Use the status dropdown to filter by invoice status

6.2 Invoice Statuses

Status Color Description

Draft Gray Work in progress, not yet sent

Issued Blue Finalized and sent to customer

Paid Green Fully paid

Partial Orange Partially paid

Overdue Red Past due date, unpaid

Void Dark Gray Cancelled

6.3 Selecting and Viewing Invoices

Click on an invoice to select it and view more details.
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Selected invoice with action buttons visible

6.4 Invoice Detail View

Double-click an invoice or click View to see full details.
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Detailed view showing all invoice information and line items

The detail view shows:

Complete header information
All line items with quantities and prices
Subtotal, tax, discounts, and total
Payment history
Notes and terms
Action buttons for PDF, Email, Payment, etc.

6.5 Creating and Editing Invoices

Click New Invoice (Ctrl+N) or select a draft invoice and click Edit.
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Invoice editor with customer selection, dates, and line items

Creating an Invoice:

1. Select a customer from the dropdown (required)
2. Set the issue date (defaults to today)
3. Set the due date (calculated from payment terms)
4. Add line items
5. Add notes if needed
6. Choose to Save as Draft or Issue

Note: Only draft invoices can be edited. Once issued, an invoice cannot be modified. To correct an issued
invoice, void it and create a new one.

6.6 Managing Line Items

Line items can only be added, edited, or removed while an invoice is in Draft status. Once an invoice is issued,
the line items are locked and cannot be modified.

Adding Line Items

Click the green Add Item button to add a new line to the invoice.
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Line item editor with product selection and pricing

Field Description

Product Select from catalog or enter custom description

Description Item description (auto-fills from product)

Quantity Number of units

Unit Price Price per unit

Discount Optional percentage or fixed amount discount

Tax Rate Tax percentage to apply
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Field Description

Amount Calculated automatically

Editing Line Items

1. Select a line item in the table by clicking on it
2. Click the Edit button
3. Modify the fields as needed
4. Click OK to save changes

Deleting Line Items

If a line item was entered in error:

1. Select the line item in the table
2. Click the red Delete button (only enabled when an item is selected)
3. Confirm the deletion when prompted

The invoice totals are automatically recalculated after deleting a line item.

Reordering Line Items

Use the ↑ Up and ↓ Down buttons to change the order of line items on the invoice.

Important: All line item operations (add, edit, delete, reorder) are only available for Draft invoices. The
buttons are disabled for Issued, Paid, or other invoice statuses.

6.7 Recording Payments

For issued invoices, click Record Payment to log payments received.

1. Enter the payment amount (or click "Pay Full Amount")
2. Select the payment date
3. Choose the payment method:

Cash
Check
Bank Transfer
Credit Card
E-Transfer
Other

4. Add a reference number (check number, transaction ID, etc.)
5. Add notes if needed
6. Click Save

The invoice status updates automatically:

Partial if payments are less than total
Paid if payments equal or exceed total
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6.8 Invoice Actions

Action Description How to Access

View Open detail view Double-click or select + View button

Edit Modify draft invoice Select draft + Edit button

Generate PDF Export to PDF file Select + Generate PDF button or Ctrl+P

Email Send via email Select + Email button or Ctrl+M

Record Payment Log payment received Select issued invoice + Record Payment

Issue Finalize draft invoice Select draft + Issue button

Void Cancel invoice Select + Void button

Delete Remove draft invoice Select draft + Delete button

6.9 Generating PDF Invoices

Create professional PDF invoices to send to customers, attach to emails, or keep for your records.
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Example PDF invoice generated with the Itemized template

How to Generate a PDF

1. Select an invoice from the invoice list
2. Click Generate PDF button (or press Ctrl+P)
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3. In the PDF Export dialog:
Select a Template from the dropdown
Choose a Save Location (defaults to Documents folder)
Optionally enable Open after export to view immediately

4. Click Export

Available Templates

Template Best For Description

Itemized
(Default)

Consulting, hourly
services

Detailed line item breakdown with quantities, rates, and tax
details

Summary Simple transactions Condensed format focusing on totals

Modern Creative agencies, tech
Contemporary design with bold color accents and visual
hierarchy

Classic Traditional businesses Professional, formal layout suitable for corporate clients

PDF Contents

Each generated PDF includes:

Header: Your company name and logo (if configured)
Invoice Details: Invoice number, issue date, due date, status
Customer Information: Name, address, contact details
Line Items Table: Description, quantity, unit price, discount, tax, and line total
Totals Section: Subtotal, tax breakdown, total amount
Payment Information: Amount paid and balance due (if applicable)
Footer: Payment terms, notes, and your contact information

Tips for Professional PDFs

Add your logo in Settings > Business to brand your invoices
Set your business information completely for professional headers
Use clear descriptions in line items for customer clarity
Add payment terms to communicate expectations
PDFs are generated at 300 DPI for high-quality printing

Troubleshooting PDF Export

Issue Solution

Logo not appearing Verify logo file exists and meets size requirements (max 2MB, 800×300px)

PDF is blank Ensure invoice has at least one line item

Cannot save PDF Check write permissions for the destination folder

Business info missing Complete your business details in Settings > Business
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7. Managing Customers
The Customers section stores all your client information. Access it via View > Customers from the menu.

7.1 Customer List

Customer list showing all clients with contact information

The list displays:

Customer/company name
Email address
Phone number
City/location
Tax Status (Taxable or Exempt)
Active status

Tax Status Column:

The Tax Status indicates whether tax is applied to invoices for this customer:

Taxable - Standard tax rates apply to all invoices
Exempt - No tax is calculated on invoices for this customer

Common reasons a customer might be tax-exempt:
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Registered charity or non-profit organization - Many jurisdictions exempt charitable organizations
from sales tax
Government agency - Federal, provincial/state, or municipal governments are often exempt
Reseller with valid certificate - Businesses purchasing for resale may be exempt with proper
documentation
Indigenous/First Nations status - Purchases by status Indigenous persons may be exempt in certain
jurisdictions
Export sales - Sales to customers outside your tax jurisdiction may be zero-rated
Specific industry exemptions - Certain industries (e.g., agriculture, healthcare) may qualify for
exemptions

Important: Always verify tax-exempt status and retain supporting documentation (exemption
certificates, tax numbers) for your records. Tax regulations vary by jurisdiction.

Use the search box to filter customers by name, email, or phone.

7.2 Adding and Editing Customers

Click New Customer (Ctrl+Shift+C) or select a customer and click Edit.
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Customer form with all contact and billing fields

Field Required Description

Name Yes Customer or company name

Email No Primary email (used for invoices)
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Field Required Description

Phone No Contact phone number

Address Line 1 No Street address

Address Line 2 No Suite, unit, building

City No City name

State/Province No State, province, or region

Postal Code No ZIP or postal code

Country No Country name (defaults to Canada)

Tax Status No Taxable or Exempt

Tax Number No Customer's tax ID (GST/HST/VAT)

Payment Terms No Default payment terms in days

Notes No Internal notes (not shown on invoices)

7.3 Deactivating Customers

Instead of permanently deleting customers (which would affect invoice history), you can deactivate them:

1. Select the customer
2. Click Delete
3. The customer is marked as inactive (soft delete)

Inactive customers:

Don't appear in customer dropdowns when creating invoices
Can be shown by toggling "Show Inactive" filter
Retain all invoice history
Can be reactivated if needed

8. Managing Products
The Products section maintains your catalog of products and services. Access it via View > Products from the
menu.

8.1 Product List
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Product catalog showing items with prices and categories

The list displays:

Product name
SKU (Stock Keeping Unit)
Unit price
Tax Class
Category
Active status

Tax Class Column:

The Tax Class determines how tax is calculated when this product is added to an invoice:

Tax Class Description

Standard Full tax rate applies (default)

Reduced Lower tax rate for qualifying items

Zero 0% tax rate (still reported for tax purposes)

Exempt No tax applied (not reported)

Common examples by tax class:

Standard: Most goods and services
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Reduced: Basic groceries, children's clothing (varies by jurisdiction)
Zero: Exported goods, prescription medications
Exempt: Financial services, medical services, educational services

Note: Tax class settings on products interact with customer tax status. If a customer is marked as Tax
Exempt, no tax is charged regardless of the product's tax class.

8.2 Adding and Editing Products

Click New Product (Ctrl+Shift+O) or select a product and click Edit.

Product form with name, pricing, and category options
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Field Required DescriptionField Required Description

Name Yes Product or service name

SKU No Unique product identifier

Unit Price Yes Default price per unit

Tax Class No Standard, Reduced, Zero, or Exempt

Category No Product category for organization

Description No Detailed description (appears on invoices)

8.3 Deactivating Products

Like customers, products use soft delete:

1. Select the product
2. Click Delete
3. The product is marked as inactive

Inactive products:

Don't appear in product dropdowns when adding line items
Can be shown with "Show Inactive" filter
Can be reactivated if needed

8.4 Using Products in Invoices

When adding a line item to an invoice:

1. Start typing the product name in the Product field
2. Select from autocomplete suggestions
3. Description and price auto-fill from the product
4. Adjust quantity as needed
5. Override price if necessary for this invoice

9. Recurring Invoices
Set up automatic invoice generation for regular clients. Access via View > Recurring or press Ctrl+R.

9.1 Recurring Schedule List
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List of recurring invoice schedules with status and next run date

The list shows:

Schedule name/description
Customer name
Frequency (Monthly, Quarterly, etc.)
Next generation date
Status (Active, Paused, Completed)

9.2 Creating a Recurring Schedule

Click New Schedule to set up automatic invoicing.
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Recurring schedule editor with frequency and template options

Field Description

Schedule Name Descriptive name for the schedule

Customer Select the customer for recurring invoices

Template Invoice Select an existing invoice as template

Auto-Issue Automatically issue generated invoices (see below)

Frequency Weekly, Bi-weekly, Monthly, Quarterly, or Annual

Start Date When to begin generating invoices

End Condition No end, End by date, or End after X occurrences
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Auto-Issue Option:

The Auto-Issue checkbox controls what happens when an invoice is generated:

Disabled (default): Invoices are created as Draft status. You can review each invoice before issuing and
sending to the customer. Recommended for schedules where amounts may vary or you want to verify
before sending.

Enabled: Invoices are automatically set to Issued status immediately upon generation. Use this for
consistent, predictable invoices that don't require review (e.g., fixed monthly retainers).

Note: If auto-issue fails (e.g., template has no line items), the invoice is still created as a draft so you
don't lose the generation.

9.3 How Recurring Invoices Work

1. On application startup, the system checks for due schedules
2. Invoices are generated from the template with the current date
3. If Auto-Issue is enabled, invoices are immediately issued
4. A notification appears showing how many invoices were created
5. Review and send drafts, or configure email automation for issued invoices

9.4 Managing Schedules

Action Description

Pause Temporarily stop generation

Resume Restart a paused schedule

Edit Modify schedule settings

View History See all invoices generated from this schedule

Generate Now Create next invoice immediately

Delete Remove the schedule

10. Reports & Analytics
The Reports section provides insights into your business performance. Access via View > Reports from the
menu.

Reports are organized in tabs:

Analytics - Top Customers, Product Performance, Revenue Trends, Period Comparison
Tax Summary - Tax collected by period and rate
Revenue Summary - Detailed revenue metrics and collection rates
Aging Report - Outstanding invoices by age bucket

10.1 Top Customers Report



user-manual.md 2025-12-21

40 / 56

Bar chart showing your highest-revenue customers

This report shows:

Customer ranking by revenue
Total revenue per customer
Invoice count per customer
Percentage of total revenue

10.2 Product Performance Report
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Pie chart showing sales by product

This report shows:

Product ranking by revenue
Revenue breakdown by product
Visual representation of product mix

10.3 Revenue Trends Report
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Line chart showing revenue over time

This report shows:

Monthly revenue totals over time
Invoice count per month
Average invoice value per month
Month-over-month growth percentage
Visual trend line for revenue patterns

10.4 Period Comparison Report
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Side-by-side comparison of two time periods

Compare metrics between two periods:

Total revenue
Invoice count
Average invoice value
Growth/decline percentage

10.5 Tax Summary Report

Available under the Tax Summary tab
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Tax summary showing collected taxes by rate

The Tax Summary report shows tax collected across your invoices:

Date Range Selection: Choose start and end dates
Status Filter: All, Draft, Issued, Paid, or Overdue
Summary Cards: Total tax collected, taxable amount, and average tax rate
Breakdown Table: Tax details by rate showing:

Tax rate percentage
Taxable amount
Tax collected
Number of invoices

Click Export CSV to download the tax data for accounting purposes.

10.6 Revenue Summary Report

Available under the Revenue Summary tab
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Revenue metrics with collection rate progress bar

The Revenue Summary provides detailed revenue metrics:

Gross Revenue: Total invoiced amount before discounts
Discounts Given: Total discounts applied
Net Revenue: Revenue after discounts
Tax Collected: Total tax on invoices
Amount Paid: Payments received
Outstanding: Unpaid invoice balance
Collection Rate: Visual progress bar showing percentage collected

Use the date range and status filters to focus on specific periods or invoice types.

10.7 Aging Report

Available under the Aging Report tab
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Receivables aging with bucket summary and invoice details

The Aging Report shows outstanding receivables by age bucket:

Bucket Description

Current Not yet due

1-30 Days 1-30 days overdue

31-60 Days 31-60 days overdue

61-90 Days 61-90 days overdue

90+ Days Over 90 days overdue

Each bucket displays:

Number of overdue invoices
Total amount outstanding
Percentage of total receivables

The detail table lists individual overdue invoices with customer name, invoice number, issue date, due date,
days overdue, and amount. Click Export CSV for collection follow-up.

10.8 Exporting Reports

All reports can be exported:
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1. Generate the report you need
2. Click Export
3. Choose format:

CSV: Data for spreadsheets
PDF: Formatted document (Advanced Reports only)

4. Charts can be exported as PNG images

11. Import & Export

11.1 Exporting Data

Export your data for backup or use in other applications.

 Export dialog with format and content
options

To Export:

1. Go to File > Export or press Ctrl+E
2. Select what to export:

All Invoices
All Customers
All Products
All Payments

3. Choose destination folder
4. Click Export

Export Format: CSV (compatible with Excel and other spreadsheet applications)

11.2 Importing Data

Import data from external sources such as spreadsheets.
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 Import wizard with field mapping options

Supported Import Types:

Customers (CSV)
Products (CSV)

To Import:

1. Go to File > Import or press Ctrl+I
2. Select import type (Customers or Products)
3. Select your CSV file
4. Map columns to fields:

The wizard auto-detects common column names
Manually adjust mappings if needed

5. Choose import mode:
Create Only: Skip existing records (by email for customers, SKU for products)
Update Only: Only update existing records
Create or Update: Create new and update existing

6. Preview the import
7. Click Import

CSV Format Example (Customers):

name,email,phone,address_line1,city,state,postal_code,country 
"Acme Corp","billing@acme.com","555-1234","123 Main St","Toronto","ON","M5V 
2T6","Canada" 

CSV Format Example (Products):

name,sku,price,description,category 
"Consulting Hour","CONSULT-HR",150.00,"One hour of consulting","Services" 

11.3 Backup and Restore
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Creating a Backup:

1. Go to File > Backup Database
2. Choose where to save the backup file
3. Click Save

The backup is a complete copy of your database that can be restored if needed.

Automatic Backups:

Enable automatic backups in Settings > Preferences:

Auto-backup on close: Creates backup when you exit the application
Max Backups: Number of backup files to retain (older backups are deleted)

Restoring from Backup:

To restore your data from a backup, you must manually replace the database file:

1. Close the application
2. Navigate to your data folder:

Windows: %USERPROFILE%\.invoice_app\
macOS: ~/.invoice_app/
Linux: ~/.invoice_app/

3. Rename invoice_app.db to invoice_app.db.old (as a precaution)
4. Copy your backup file to this location
5. Rename the backup file to invoice_app.db
6. Restart the application

12. Help & Support

12.1 In-App Help

Press F1 at any time to access the Help system.



user-manual.md 2025-12-21

50 / 56

Built-in help with searchable topics and tutorials

The Help system includes:

Quick Start Guide: Get started in minutes
Feature Guides: Detailed explanations of each feature
Email Configuration: Setup guides for Gmail, Outlook, Yahoo
Keyboard Shortcuts: Complete shortcut reference
Troubleshooting: Solutions to common problems
Database Backup: How to protect your data

The help window can be moved and left open while you continue working with the main application window.
This allows you to reference instructions while performing tasks.

You can also export the entire help system to PDF for offline reference.

12.2 Getting Help

Resource How to Access

In-App Help Press F1 or Help > User Guide

Keyboard Shortcuts Help > Keyboard Shortcuts

About (Version Info) Help > About
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12.3 Reporting Issues

If you encounter a bug or issue:

1. Note the steps to reproduce the problem
2. Check the application version (Help > About)
3. Report the issue at: GitHub Issues

Include:

Operating system and version
Application version
Steps to reproduce
Error messages (if any)
Screenshots (if helpful)

13. Keyboard Shortcuts

Create New Items

Shortcut Action

Ctrl+N New Invoice

Ctrl+Shift+C New Customer

Ctrl+Shift+O New Product

View Navigation

Shortcut Action

Alt+1 Go to Dashboard

Alt+2 Go to Invoices

Alt+3 Go to Customers

Alt+4 Go to Products

Alt+5 Go to Recurring Invoices

Alt+6 Go to Reports

Ctrl+R View Recurring Invoices

General

Shortcut Action

Ctrl+, Open Settings

Ctrl+E Export Data

https://github.com/stephenbogner/invoice-app/issues
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Shortcut Action

Ctrl+I Import Data

F5 Refresh Current View

Ctrl+Shift+T Toggle Dark/Light Mode

F1 Open Help

Ctrl+Q Quit Application

Edit Operations

Shortcut Action

Ctrl+Z Undo

Ctrl+Y Redo

Ctrl+X Cut

Ctrl+C Copy

Ctrl+V Paste

Ctrl+A Select All

Dialog Navigation

Shortcut Action

Esc Close Dialog / Cancel

Table Navigation

Key Action

Up/Down Arrow Navigate rows

Enter Open selected item

Home First row

End Last row

Page Up/Down Scroll page

Dialog Navigation

Key Action

Tab Next field

Shift+Tab Previous field
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Key Action

Enter Activate default button

Space Toggle checkbox

Escape Close / Cancel

macOS Users: Replace Ctrl with Cmd for all shortcuts (e.g., Cmd+N, Cmd+S).

14. Troubleshooting

14.1 Application Won't Start

Windows:

SmartScreen warning: Click "More info" then "Run anyway"
Missing DLL errors: Ensure you extracted all files from the ZIP
Try running as administrator: Right-click > Run as administrator

macOS:

Gatekeeper block: System Preferences > Security & Privacy > Click "Open Anyway"
Damaged app message: Right-click the app > Open > Click "Open"

Linux:

Permission denied: Run chmod +x SoloStaff_Invoice
Missing libraries: Install Qt dependencies:

# Ubuntu/Debian 
sudo apt install libxcb-cursor0 libxcb-xinerama0 
 
# Fedora 
sudo dnf install xcb-util-cursor 

14.2 Database Errors

Problem: "Database locked" or corruption errors

Solutions:

1. Close other instances - Only one instance should run at a time

2. Check file permissions - Ensure write access to the database folder

3. Restore from backup:

Close the application
Follow the restore procedure in Section 11.3
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4. Reset database (loses all data):

Delete the database file (see Data Locations in Section 2)
Restart the application (creates new database)

14.3 Email Sending Fails

Problem: Emails don't send or show errors

Checklist:

1. Did you configure email? You must configure SMTP settings before sending emails (see Section 5.6)

2. Test connection - Go to Settings > Email > Test Connection

3. Gmail users - You must use an App Password:

Enable 2-Step Verification on your Google account
Generate App Password at App Passwords
Use the app password, not your regular password

4. Check port - Common ports: 587 (TLS), 465 (SSL)

5. Enable TLS/STARTTLS - Most providers require encryption

6. Check firewall - Ensure SMTP port is not blocked

14.4 PDF Generation Fails

Problem: PDFs don't generate or are blank

Solutions:

1. Check disk space - Ensure sufficient free space

2. Check permissions - Verify write access to output folder

3. Try different location - Save to Documents folder

4. Check invoice data - Ensure customer and line items are present

14.5 Display Issues

Problem: UI appears blurry, too small, or incorrectly scaled

Windows:

Right-click executable > Properties > Compatibility
Change high DPI settings > Override scaling behavior

Linux:

export QT_SCALE_FACTOR=1.5 
./SoloStaff_Invoice 

https://myaccount.google.com/signinoptions/two-step-verification
https://myaccount.google.com/apppasswords
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All Platforms:

Adjust font size: Settings > Accessibility > Font Size

14.6 Slow Performance

Problem: Application is sluggish

Solutions:

1. Large database - Archive old invoices or export to CSV

2. Check disk - SSD recommended for database storage

3. Close other applications - Free up system memory

15. Appendix

A. Glossary

Term Definition

Draft An invoice that hasn't been finalized or sent

Issued A finalized invoice sent to the customer

Line Item A single product or service on an invoice

Recurring Invoice An invoice generated automatically on a schedule

SKU Stock Keeping Unit - unique product identifier

SMTP Simple Mail Transfer Protocol - for sending emails

Void A cancelled invoice that remains in records for audit

Soft Delete Marking a record as inactive instead of permanently deleting

B. Data Locations by Platform

Windows:

Data Location

Database %USERPROFILE%\.invoice_app\invoice_app.db

Settings %APPDATA%\InvoiceApplication\config.json

Backups %USERPROFILE%\.invoice_app\backups\

macOS:

Data Location
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Data Location

Database ~/.invoice_app/invoice_app.db

Settings ~/Library/Application Support/InvoiceApplication/config.json

Backups ~/.invoice_app/backups/

Linux:

Data Location

Database ~/.invoice_app/invoice_app.db

Settings ~/.config/invoice-application/config.json

Backups ~/.invoice_app/backups/

C. CSV Import Field Mapping

Customers - Recognized Column Names:

name, customer_name, company, company_name
email, email_address, e-mail
phone, phone_number, telephone
address, address_line1, street, street_address
city, town
state, province, region
postal_code, zip, zip_code, postcode
country

Products - Recognized Column Names:

name, product_name, item, item_name
sku, product_code, item_code
price, unit_price, cost
description, desc
category, type, product_type

D. Support Resources

Documentation: This user manual
In-App Help: Press F1
GitHub: github.com/stephenbogner/invoice-app
Issues: GitHub Issues
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